Symptoms:
Suppose you've paid for a year long license of one of our Products. 3 months down the track, you notice an ugly looking alert saying to "renew" or "reactivate" your license.
What's going on there?



Cause:
In order to keep track of our licenses, Amristar products regularly communicate with our license server in order to reactivate the license and continue normal operation. If everything goes smoothly, this should be totally transparent to the user, but if the server cannot access our license server (whether intentionally or accidentally), then manual intervention is required.

To test a product's connectivity to the Amristar Licensing server, log into the machine which the product is running on, open a terminal / command prompt window and run:

telnet licensing.amristar.com 443


Solution:

Manual Activation

The quickest and easiest way to get your product working again is to click the link that prompts to "reactivate" or "rewnew" the license and follow the prompts. This will use the client's internet connection (rather than the server's) to reactivate the product.


Automated Server Activation

Of course, this will only last as long as the next activation period. The more permanent solution is to do the connectivity test mentioned above. If the server does not have access to the licensing server, you may want to talk to your IT department to open up a firewall rule to allow access to that website.